summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-22 01:09:14 +0200
committerMarius Bakke <marius@gnu.org>2022-07-22 01:09:14 +0200
commit9044b086ddca64a62966a83cbf1b82d32dece89e (patch)
tree2c7f910c9100b2f2a752d07fe0ec44be83fb7600 /gnu/packages/python-check.scm
parent5dfc6ab1ab292b87ceea144aa661d0e64c834031 (diff)
parentabea091dbef2d44e6eb46bd2413bdf917e14d095 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1e59911299..fa382f6f35 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -127,6 +127,26 @@ written in pure Python.")
interfaces with pytest.")
(license license:expat)))
+(define-public python-pytest-cram
+ (package
+ (name "python-pytest-cram")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-cram" version))
+ (sha256
+ (base32
+ "0405ymmrsv6ii2qhq35nxfjkb402sdb6d13xnk53jql3ybgmiqq0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-cram python-pytest))
+ (home-page "https://github.com/tbekolay/pytest-cram")
+ (synopsis "Run cram tests with pytest.")
+ (description "Cram tests command line applications; Pytest tests Python
+applications. @code{pytest-cram} tests Python command line applications by
+letting you write your Python API tests with pytest, and your command line
+tests in cram.")
+ (license license:expat)))
+
(define-public python-pytest-csv
(package
(name "python-pytest-csv")