summaryrefslogtreecommitdiff
path: root/gnu/packages/python-compression.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-23 00:29:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-23 13:57:47 +0100
commit48a5dc0ffb9f1c5ed6c0d67afdd442b3b340cb25 (patch)
tree5ac0ced0266d2b5b6d96a57698f528652962fbdc /gnu/packages/python-compression.scm
parent3ab9adba57c529f524e63ffbc663f5ddf8770752 (diff)
gnu: python-ppmd-cffi: Update to 0.5.0.
* gnu/packages/python-compression.scm (python-ppmd-cffi): Update to 0.5.0. [native-inputs]: Remove python-setuptools and python-pep517; add python-hypothesis.
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 1426ad9f09..7dd01d611e 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -127,21 +127,20 @@ and decompression by implementing Python bindings for the ISA-L library.")
(define-public python-ppmd-cffi
(package
(name "python-ppmd-cffi")
- (version "0.3.3")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ppmd-cffi" version))
(sha256
(base32
- "01wcd9l6pp6hivdmd275qh9dhcwficjqfl67hxix5n07vvq7jzz0"))))
+ "0vprpl29fkflqx0m6anfpx7q7i4cw0d0qxcdm91k4pl82dcad81g"))))
(build-system python-build-system)
(propagated-inputs
(list python-cffi))
(native-inputs
- (list python-setuptools
+ (list python-hypothesis
python-setuptools-scm
- python-pep517
python-coverage
python-pytest
python-pytest-cov))