summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-02 10:36:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:02 +0300
commit424e0ea4e5f093f20af322e8e54a86f984881591 (patch)
tree5eaa4cf157ef991c558a60bb1bdb49e673c38b25 /gnu/packages/python-crypto.scm
parent227f4cacf6d93318dd322b675d41e311cee1f4f6 (diff)
gnu: python-cryptography: Update to 41.0.4.
* gnu/packages/python-crypto.scm (python-cryptography): Update to 41.0.4. (python-cryptography-rust)[arguments]: Don't install source. [cargo-inputs]: Add rust-foreign-types-0.3 Replace rust-asn1-0.13 with 0.15, rust-pyo3-0.15 with 0.18. Remove rust-chrono-0.4.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 0a4155770b..e28d1de837 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -506,14 +506,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "40.0.2")
+ (version "41.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "16awbsm13vdksm98dybwvmpy2y1l636bq7g0s93scksrp0r0sg63"))))
+ "06pm952pr6f31pzwh5fb68zryqyss0hg9cbggxm15z15844w7svz"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -568,6 +568,7 @@ ciphers, message digests and key derivation functions.")
(guix build utils)
(srfi srfi-1)
(ice-9 match))
+ #:install-source? #f
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'chdir
@@ -595,16 +596,16 @@ ciphers, message digests and key derivation functions.")
(install-file "target/release/libcryptography_rust.so"
(string-append #$output "/lib")))))
#:cargo-inputs
- `(("rust-asn1-0.13" ,rust-asn1-0.13)
+ `(("rust-asn1" ,rust-asn1-0.15)
("rust-cc" ,rust-cc-1)
- ("rust-chrono-0.4" ,rust-chrono-0.4)
- ("rust-foreign-types-shared-0.1" ,rust-foreign-types-shared-0.1)
- ("rust-once-cell-1" ,rust-once-cell-1)
- ("rust-openssl-0.10" ,rust-openssl-0.10)
- ("rust-openssl-sys-0.9" ,rust-openssl-sys-0.9)
- ("rust-ouroboros-0.15" ,rust-ouroboros-0.15)
- ("rust-pem-1" ,rust-pem-1)
- ("rust-pyo3-0.15" ,rust-pyo3-0.15))))
+ ("rust-foreign-types" ,rust-foreign-types-0.3)
+ ("rust-foreign-types-shared" ,rust-foreign-types-shared-0.1)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-openssl-sys" ,rust-openssl-sys-0.9)
+ ("rust-ouroboros" ,rust-ouroboros-0.15)
+ ("rust-pem" ,rust-pem-1)
+ ("rust-pyo3" ,rust-pyo3-0.18))))
(native-inputs (list pkg-config python python-cffi))
;; XXX: Adding rust-openssl-sys-0.9 is needed because #:cargo-inputs
;; doesn't honor propagated-inputs.