summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-11 18:20:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:37 +0300
commita91628366aee57020bb758cdee2229e58993f4d9 (patch)
treeaf78ba6a582f66b7ebdc7d7f26fc7ed2a2a4a5d3 /gnu/packages/python-crypto.scm
parenta3ba943b6ffb6aed799dcbeebfd044536ded2f02 (diff)
gnu: python-cryptography: Update to 40.0.2.
* gnu/packages/python-crypto.scm (python-cryptography): Update to 40.0.2. (python-cryptography-rust)[cargo-inputs]: Move rust-cc-1 here from cargo-development-inputs. [cargo-development-inputs]: Remove field.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 91ac7c0c31..bcef7c5db6 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -495,14 +495,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "40.0.1")
+ (version "40.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "0wilrilfcyl78caxcpna2k3aya6qamppwv4j35262pz9n7wg40r8"))))
+ "16awbsm13vdksm98dybwvmpy2y1l636bq7g0s93scksrp0r0sg63"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -585,6 +585,7 @@ ciphers, message digests and key derivation functions.")
(string-append #$output "/lib")))))
#:cargo-inputs
`(("rust-asn1-0.13" ,rust-asn1-0.13)
+ ("rust-cc" ,rust-cc-1)
("rust-chrono-0.4" ,rust-chrono-0.4)
("rust-foreign-types-shared-0.1" ,rust-foreign-types-shared-0.1)
("rust-once-cell-1" ,rust-once-cell-1)
@@ -592,9 +593,7 @@ ciphers, message digests and key derivation functions.")
("rust-openssl-sys-0.9" ,rust-openssl-sys-0.9)
("rust-ouroboros-0.15" ,rust-ouroboros-0.15)
("rust-pem-1" ,rust-pem-1)
- ("rust-pyo3-0.15" ,rust-pyo3-0.15))
- #:cargo-development-inputs
- `(("rust-cc" ,rust-cc-1))))
+ ("rust-pyo3-0.15" ,rust-pyo3-0.15))))
(native-inputs (list pkg-config python python-cffi))
;; XXX: Adding rust-openssl-sys-0.9 is needed because #:cargo-inputs
;; doesn't honor propagated-inputs.