summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-25 18:34:50 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-25 18:34:54 +0100
commit1e5aabc572256290cb71ab455acdeec477b2e25a (patch)
tree8f69ef43d3643afcc41064760015d53785b96459 /gnu/packages/python-crypto.scm
parent035b216d9ad655b8b4fc4a4741d825c4731a4ee0 (diff)
gnu: Remove python-potr.
The last release of the package dates from 2018. According to its self-description: "This software is experimental and potentially insecure. Do not rely on it" It depends on the cryptography library python-pycrypto, which has had its last release in 2013 and "is unmaintained, obsolete, and contains security vulnerabilities" according to its homepage. * gnu/packages/python-crypto.scm (python-potr): Delete variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9071c4cf6..273e1bf30c 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -75,30 +75,6 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
-(define-public python-potr
- (package
- (name "python-potr")
- (version "1.0.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/python-otr/pure-python-otr")
- (commit version)))
- (file-name
- (git-file-name name version))
- (sha256
- (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-pycrypto))
- (synopsis "Python OTR Implementation")
- (description "Python OTR is an Off-The-Record Protocol Implementation in
-Python. It does not bind to libotr.")
- (home-page "https://github.com/python-otr/pure-python-otr")
- (license license:lgpl3+)))
-
(define-public python-base58
(package
(name "python-base58")