summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2023-05-13 13:31:38 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-22 17:05:22 +0200
commit75ae763b4e09f5f7f0b21d28b4f308bcb02f1876 (patch)
tree810900344d420aad2f51833e9bcb88042a4abc1b /gnu/packages/python-crypto.scm
parentef5861693682012f5473d7375c242ff456098821 (diff)
gnu: python-txtorcon: Fix failing build.
Oops, I forgot to add a copyright line - this version fixes that. * gnu/packages/python-crypto.scm (python-txtorcon): Fix failing build. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index b1d94e85b8..be3ab5d0be 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1253,7 +1254,12 @@ Password-Authenticated Key Exchange algorithm.")
(uri (pypi-uri "txtorcon" version))
(sha256
(base32
- "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))))
+ "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(substitute* "txtorcon/controller.py"
+ (("from collections import Sequence")
+ "from collections.abc import Sequence")))))
(build-system python-build-system)
(arguments
;; The tests fail immediately due to a missing file. Reported upstream: