summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-14 21:24:39 +0200
committerMarius Bakke <marius@gnu.org>2020-07-14 21:41:39 +0200
commitf5e3f02fdd668c24717b63f0289394cfd704f726 (patch)
tree0a5439346328af4688efc772ad55f921fb76cf47 /gnu/packages/python-crypto.scm
parent2008b8b7afea917d3ebc42679c447a4c8e8e9733 (diff)
gnu: python-pynacl: Update to 1.4.0.
* gnu/packages/python-crypto.scm (python-pynacl): Update to 1.4.0. [source](snippet): Adjust to fix spurious build requirement. [arguments]: Add #:modules. Replace check phase with custom pytest invocation.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index da7b8edeba..97f5903840 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -739,26 +739,44 @@ PKCS#8, PKCS#12, PKCS#5, X.509 and TSP.")
(define-public python-pynacl
(package
(name "python-pynacl")
- (version "1.3.0")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "PyNaCl" version))
(modules '((guix build utils)))
- ;; Remove bundled libsodium.
- (snippet '(begin (delete-file-recursively "src/libsodium")
- #t))
+ (snippet
+ '(begin
+ ;; Remove spurious dependency on python-wheel, can be removed
+ ;; for 1.5.
+ (substitute* "setup.py"
+ (("\"wheel\"") ""))
+ ;; Remove bundled libsodium.
+ (delete-file-recursively "src/libsodium")
+ #t))
(sha256
(base32
- "0330wyvggm19xhmwmz9rrr97lzbv3siwfy50gmax3vvgs7nh0q8c"))))
+ "01b56hxrbif3hx8l6rwz5kljrgvlbj7shmmd2rjh0hn7974a5sal"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ `(#:modules (,@%python-build-system-modules
+ (guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26))
+ #:phases
+ (modify-phases (@ (guix build python-build-system) %standard-phases)
(add-before 'build 'use-system-sodium
(lambda _
(setenv "SODIUM_INSTALL" "system")
- #t)))))
+ #t))
+ (replace 'check
+ (lambda _
+ (let ((build-directory
+ (car (scandir "build" (cut string-prefix? "lib" <>)))))
+ (setenv "PYTHONPATH"
+ (string-append "./build/" build-directory ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)))