summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-17 19:17:39 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-17 19:17:39 +0200
commit216d7bdb738e05675bbb128d582851bdc9b85aaa (patch)
tree0535efa1427ebc5b14ac10ccf03be17673a8c909 /gnu/packages/python-crypto.scm
parentd3c7ca3c40fd613cfb3fb8f41e8ea064b438414a (diff)
parent50dd91bc30634c75c0001cfd38bbcc2fbbeb894e (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e1609a463d..f265e7cd6e 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
@@ -1361,14 +1361,13 @@ and Backlog for a list of what is and is not currently supported.")
(define-public python-secretstorage
(package
(name "python-secretstorage")
- (version "3.3.1")
+ (version "3.3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "SecretStorage" version))
(sha256
- (base32
- "15ginv4gzxrx77n7517xnvf2jcpqc6ran12s951hc85zlr8nqrpx"))))
+ (base32 "0xxxxr77sgmjm1rqzdd1rkan9xg0qmv8awc1pb9adv39ycz560r4"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; Tests require a running dbus service.
@@ -1443,17 +1442,23 @@ certificates, signing and building trust bundles.")
(define-public python-jeepney
(package
(name "python-jeepney")
- (version "0.6.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jeepney" version))
(sha256
- (base32 "0mw6ch5s4czpmsiwqwhcidgk27858pl8vlvb7acrxjkm4ribcnbx"))))
- (build-system python-build-system)
+ (base32 "01jqrk7pn94i7bpmj834pjrw7id659gfag6wpbv04fcpap94izjy"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-testpath python-tornado python-trio python-pytest
- python-pytest-trio))
+ (list python-async-timeout
+ python-testpath
+ python-trio
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-trio
+ ;; For the build backend
+ python-flit-core))
(home-page "https://gitlab.com/takluyver/jeepney")
(synopsis "Low-level, pure Python DBus protocol wrapper")
(description