summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 20:59:36 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 20:59:36 -0400
commit779575cb338c13d0ab91aa4230e75c0dc63b00ec (patch)
tree7c3287f1b22ddf2b3be7c6b387427bc4f9a4e9fb /gnu/packages/python-crypto.scm
parent94a2e94a26fde164614f42083134e42536890a8d (diff)
gnu: python-ecdsa: Fix faulty commit.
Fix previous commit, which did not properly add the test to be skipped and repeated the existing skipped test. There is only one new test to be skipped. * gnu/packages/python-crypto.scm (python-ecdsa)[arguments]: In the 'check' phase, properly format the string for skipped tests.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 4e1aec4e0a..b1d94e85b8 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -226,15 +226,12 @@ Python interface around SSH networking concepts.")
"pytest"
"-vv"
"-k"
- "not test_multithreading_with_interrupts"
- ;; The following test fails and will be fixed in the
- ;; next release after v0.18. See
- ;; <https://github.com/tlsfuzzer/python-ecdsa/issues/307>.
- "-k"
- "not test_add_different_scale_points"
- ;; The following test needs a KeyboardInterrupt to occur.
- "-k"
- "not test_multithreading_with_interrupts"))))))
+ (string-append
+ "not test_multithreading_with_interrupts "
+ ;; The following test fails and will be fixed in the
+ ;; next release after v0.18. See
+ ;; <https://github.com/tlsfuzzer/python-ecdsa/issues/307>.
+ "and not test_add_different_scale_points")))))))
(propagated-inputs
(list python-six))
(native-inputs