summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 20:46:29 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-23 20:48:20 -0400
commit94a2e94a26fde164614f42083134e42536890a8d (patch)
tree006f0425bfc67fbe7fba2725bb0fbfcd42f7262d /gnu/packages/python-crypto.scm
parent4e0186ec7fb4695565a18df939e7dc4755241a3f (diff)
gnu: python-ecdsa: Skip two failing tests.
* gnu/packages/python-crypto.scm (python-ecdsa)[arguments]: In 'check' phase, skip a couple more tests.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 3e7704bf48..4e1aec4e0a 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -226,6 +226,14 @@ Python interface around SSH networking concepts.")
"pytest"
"-vv"
"-k"
+ "not test_multithreading_with_interrupts"
+ ;; The following test fails and will be fixed in the
+ ;; next release after v0.18. See
+ ;; <https://github.com/tlsfuzzer/python-ecdsa/issues/307>.
+ "-k"
+ "not test_add_different_scale_points"
+ ;; The following test needs a KeyboardInterrupt to occur.
+ "-k"
"not test_multithreading_with_interrupts"))))))
(propagated-inputs
(list python-six))