summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-29 10:07:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-29 13:23:45 -0400
commita1b826b3387fcb862993f9d3490faafd150451e0 (patch)
treebd97c039c1aa42ff3af2ec25a80c6629db4ce650 /gnu/packages/python-crypto.scm
parenta1d4e562f1061d3300ed9cb37e6a40bddccf0197 (diff)
gnu: python-trustme: Update to 0.9.0.
* gnu/packages/python-crypto.scm (python-trustme): Update to 0.9.0. [build-system]: Use pyproject-build-system. [arguments]: Delete field. [propagated-inputs]: Add python-idna and python-ipaddress.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9071c4cf6..c3e36ff2e4 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1503,21 +1503,14 @@ items and collections, editing items, locking and unlocking collections
(define-public python-trustme
(package
(name "python-trustme")
- (version "0.6.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trustme" version))
(sha256
- (base32 "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (base32 "0v2qzszmyazfgc1snicdr4b4qdajpjd4pbinpgrn9vfff0yv41sy"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-more-itertools
python-pyopenssl
@@ -1526,7 +1519,9 @@ items and collections, editing items, locking and unlocking collections
python-service-identity
python-zipp))
(propagated-inputs
- (list python-cryptography))
+ (list python-cryptography
+ python-idna
+ python-ipaddress))
(home-page "https://github.com/python-trio/trustme")
(synopsis "Fake a certificate authority for tests")
(description