summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-07-03 15:43:00 +0100
committerHilton Chain <hako@ultrarare.space>2023-08-24 12:39:42 +0800
commitc49c43d44c45015dc7ef251a171a48bdba0b8b5a (patch)
treef5c0f590ce8d974c2c9ef00d4bdbf884e910e78c /gnu/packages/python-crypto.scm
parent3ce3466311953cc5f00a4fb34ff094a9a3501399 (diff)
gnu: python-asn1crypto: Update to 1.5.1.
* gnu/packages/python-crypto.scm (python-asn1crypto): Update to 1.5.1. [description]: Adjust according to lint warning. Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index cfd1146f06..3d347fee0b 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -735,7 +735,7 @@ ECB and OFB).")
(define-public python-asn1crypto
(package
(name "python-asn1crypto")
- (version "1.4.0")
+ (version "1.5.1")
(source
(origin
(method git-fetch)
@@ -745,7 +745,7 @@ ECB and OFB).")
(file-name (git-file-name name version))
(sha256
(base32
- "19abibn6jw20mzi1ln4n9jjvpdka8ygm4m439hplyrdfqbvgm01r"))))
+ "1qsg06qrqnzixmrm65ibg503y2gffd675h1si4jgh92s315w1jrk"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -754,9 +754,10 @@ ECB and OFB).")
(invoke "python" "run.py" "tests"))))))
(home-page "https://github.com/wbond/asn1crypto")
(synopsis "ASN.1 parser and serializer in Python")
- (description "asn1crypto is an ASN.1 parser and serializer with definitions
-for private keys, public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7,
-PKCS#8, PKCS#12, PKCS#5, X.509 and TSP.")
+ (description
+ "@code{asn1crypto} is an ASN.1 parser and serializer with definitions for
+private keys, public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
+PKCS#12, PKCS#5, X.509 and TSP.")
(license license:expat)))
(define-public python-pynacl