summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-11-04 15:02:30 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-04 22:26:37 +0100
commitf76ffc3ea607aa65820aaa87d9b681ba535a7e5d (patch)
treee0e6a51b72d36c7084fd5ddeed3c1bc9e1c80ea2 /gnu/packages/python-science.scm
parentff9d32df33dc80e5a04bdff80f780cb09f726006 (diff)
gnu: Add python-meshzoo.
* gnu/packages/python-science.scm (python-meshzoo): New variable. Change-Id: Ia41d62ebd6c4cb3c22ebe0668c36279a9ca191ac Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 949cd11929..e836235a6b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -420,6 +420,31 @@ manipulation and analysis, in the style of the Polygon object in the Shapely
library.")
(license license:expat)))
+(define-public python-meshzoo
+ (package
+ (name "python-meshzoo")
+ (version "0.9.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/diego-hayashi/meshzoo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "107byfppbq16fqyp2hw7ydcvvahspzq0hzvlvzqg2zxi1aigbr68"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-numpy))
+ (native-inputs (list python-flit-core python-matplotlib python-pytest))
+ (home-page "https://github.com/diego-hayashi/meshzoo")
+ (synopsis "Mesh generator for simple geometries")
+ (description
+ "@code{meshzoo} is a mesh generator for finite element or finite
+volume computations for simple domains like regular polygons, disks,
+spheres, cubes, etc.")
+ (license license:gpl3+)))
+
(define-public python-tspex
(package
(name "python-tspex")