summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-05-20 15:31:20 -0300
committerVinicius Monego <monego@posteo.net>2023-06-25 10:43:22 -0300
commita38f5a71adaf73335b4c07145893d80745bc718d (patch)
tree8d80ef496db55f4406058c90700784e943b463ef /gnu/packages/python-science.scm
parentb08a1f3ce11a806da1a74e46d90ca4ac6d1ce60a (diff)
gnu: Add python-xarray-einstats.
* gnu/packages/python-science.scm (python-xarray-einstats): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 90d22d8d1b..81cd17693e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -730,6 +730,30 @@ large and growing library of domain-agnostic functions for advanced analytics
and visualization with these data structures.")
(license license:asl2.0)))
+(define-public python-xarray-einstats
+ (package
+ (name "python-xarray-einstats")
+ (version "0.5.1")
+ (source (origin
+ (method git-fetch) ; no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/arviz-devs/xarray-einstats")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gg7p2lq7zxic64nbr6a8ynizs8rjzb29fnqib7hw3lmp13wsfm0"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-einops python-flit-core python-numba
+ python-pytest))
+ (propagated-inputs (list python-numpy python-scipy python-xarray))
+ (home-page "https://einstats.python.arviz.org/en/latest/")
+ (synopsis "Stats, linear algebra and einops for xarray")
+ (description
+ "@code{xarray_einstats} provides wrappers around some NumPy and SciPy
+functions and around einops with an API and features adapted to xarray.")
+ (license license:asl2.0)))
+
(define-public python-msgpack-numpy
(package
(name "python-msgpack-numpy")