summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-07 16:59:11 -0500
committerLudovic Courtès <ludo@gnu.org>2022-10-18 14:41:10 +0200
commit70cac2829fe180099c3ea7637053ff8bf1cc1760 (patch)
tree8c099b9b0e272986e63b414b1634fea05d6b4cff /gnu/packages/python-science.scm
parent7460b06a2d88c93eb7c4539407276982eaaef2a4 (diff)
gnu: Add python-simple-pid.
* gnu/packages/python-science.scm (python-simple-pid): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 8e38e69d97..94a4c922a5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1482,6 +1483,30 @@ of use as pickling or @code{numpy.save}, but with the language
interoperability offered by HDF5.")
(license license:bsd-3)))
+(define-public python-simple-pid
+ (package
+ (name "python-simple-pid")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "simple-pid" version))
+ (sha256
+ (base32
+ "094mz6rmfq1h0gpns5vlxb7xf9297hlkhndw7g9k95ziqfkv7mk0"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "tests/")))))))
+ (home-page "https://github.com/m-lundberg/simple-pid")
+ (synopsis "Easy to use PID controller")
+ (description "This package provides a simple and easy-to-use @acronym{PID,
+proportional-integral-derivative} controller.")
+ (license license:expat)))
+
(define-public python-opt-einsum
(package
(name "python-opt-einsum")