summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-10-07 00:08:57 -0300
committerVinicius Monego <monego@posteo.net>2023-11-03 19:25:35 -0300
commita7d56852e3c177db614aebc1934b00ee17014472 (patch)
tree319e7a4f5c3f430b4e13f427cddf72131c3ba50d /gnu/packages/python-science.scm
parent9642b1c7af6afcad8195593266a6080b49211128 (diff)
gnu: Add python-salib.
* gnu/packages/python-science.scm (python-salib): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index efddd060a4..655bd2e942 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2030,6 +2030,33 @@ Out-of-Core DataFrames (similar to Pandas), to visualize and explore big
tabular datasets. This package provides the core modules of Vaex.")
(license license:expat)))
+(define-public python-salib
+ (package
+ (name "python-salib")
+ (version "1.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SALib/SALib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18xfyzircsx2q2lmfc9lxb6xvkxicnc83qzghd7df1jsprr5ymch"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-matplotlib
+ python-multiprocess
+ python-numpy
+ python-pandas
+ python-scipy))
+ (native-inputs (list python-hatchling python-pytest python-pytest-cov))
+ (home-page "https://salib.readthedocs.io/en/latest/")
+ (synopsis "Tools for global sensitivity analysis")
+ (description "SALib provides tools for global sensitivity analysis. It
+contains Sobol', Morris, FAST, DGSM, PAWN, HDMR, Moment Independent and
+fractional factorial methods.")
+ (license license:expat)))
+
(define-public python-pylems
(package
(name "python-pylems")