summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2022-06-08 18:52:57 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 21:16:14 +0000
commita879dd8b360adcf8f7d69c317dec8cae0f48270c (patch)
tree526370ce9c91d526a550be91b779608f9b7aa6ec /gnu/packages/python-science.scm
parent560b4687e534836943f50ba5d56d779ddc1adeb0 (diff)
gnu: Add python-pandarallel.
* gnu/packages/python-science.scm (python-pandarallel): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index a0123dac21..2b4e74f9be 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -766,6 +766,42 @@ a convention of suggesting best recommended practices for using
@code{python-pandas}.")
(license license:bsd-3)))
+(define-public python-pandarallel
+ (package
+ (name "python-pandarallel")
+ (version "1.6.5")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI
+ (uri (git-reference
+ (url "https://github.com/nalepae/pandarallel/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r2wlxlwp4wia0vm15k4cp421mwa20k4k5g2ml01inprj8bl1p0p"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-n" (number->string (parallel-job-count)))))
+ (propagated-inputs
+ (list python-dill
+ python-pandas
+ python-psutil))
+ (native-inputs
+ (list python-mkdocs-material
+ python-numpy
+ python-pytest
+ python-pytest-cov
+ python-pytest-xdist))
+ (home-page "https://nalepae.github.io/pandarallel/")
+ (synopsis "Tool to parallelize Pandas operations across CPUs")
+ (description
+ "@code{pandarallel} allows any Pandas user to take advantage of their
+multi-core computer, while Pandas uses only one core. @code{pandarallel} also
+offers nice progress bars (available on Notebook and terminal) to get an rough
+idea of the remaining amount of computation to be done.")
+ (license license:bsd-3)))
+
(define-public python-pandera
(package
(name "python-pandera")