summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-03-26 22:33:33 -0300
committerVinicius Monego <monego@posteo.net>2023-06-25 10:43:22 -0300
commitb08a1f3ce11a806da1a74e46d90ca4ac6d1ce60a (patch)
treeb07678ef1fa9d92a57456e3f3ed077f82667311a /gnu/packages/python-science.scm
parent6bc2fbc14c387e74005f5679aae738ac7183e060 (diff)
gnu: python-xarray: Update to 2023.6.0.
* gnu/packages/python-science.scm (python-xarray): Update to 2023.6.0. [build-system]: Switch to pyproject-build-system. [arguments]: Do not override the check phase.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 852bba3b3e..90d22d8d1b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
@@ -706,24 +706,18 @@ multiple deep learning frameworks.")
(define-public python-xarray
(package
(name "python-xarray")
- (version "0.15.1")
+ (version "2023.6.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "xarray" version))
(sha256
(base32
- "1yx8j66b7rn10m2l6gmn8yr9cn38pi5cj0x0wwpy4hdnhy6i7qv4"))))
- (build-system python-build-system)
+ "1339fz5gxkizq02h6vn19546x9p4c3nd9ipzpcg39h7gwhg26yi6"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-setuptools-scm python-pytest))
(propagated-inputs
(list python-numpy python-pandas))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest"))))))
(home-page "https://github.com/pydata/xarray")
(synopsis "N-D labeled arrays and datasets")
(description "Xarray (formerly xray) makes working with labelled