summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-02 13:51:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-02 14:37:38 +0200
commit4bc130dcc0608ad01fcf13934a101498018cba99 (patch)
treef780e01ba6c412c07c538ea84a3dc28e551bb85d /gnu/packages/python-science.scm
parentd4b0dc047f9a1d44a1448d24794befcfc6ae90a4 (diff)
gnu: Add python-geosketch.
* gnu/packages/python-science.scm (python-geosketch): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 2f4f1818f3..ff82a97fc9 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -564,6 +564,29 @@ higher scores.")
analysis} (PCA), SVD, and eigendecompositions via randomized methods")
(license license:bsd-3)))
+(define-public python-geosketch
+ (package
+ (name "python-geosketch")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "geosketch" version))
+ (sha256
+ (base32
+ "0knch5h0p8xpm8bi3b5mxyaf1ywwimrsdmbnc1xr5icidcv9gzmv"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #false)) ;there are none
+ (propagated-inputs (list python-fbpca python-numpy python-scikit-learn))
+ (home-page "https://github.com/brianhie/geosketch")
+ (synopsis "Geometry-preserving random sampling")
+ (description "geosketch is a Python package that implements the geometric
+sketching algorithm described by Brian Hie, Hyunghoon Cho, Benjamin DeMeo,
+Bryan Bryson, and Bonnie Berger in \"Geometric sketching compactly summarizes
+the single-cell transcriptomic landscape\", Cell Systems (2019). This package
+provides an example implementation of the algorithm as well as scripts
+necessary for reproducing the experiments in the paper.")
+ (license license:expat)))
+
(define-public python-xarray
(package
(name "python-xarray")