summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:54:06 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-03-21 13:56:47 +0100
commit9f882daf1194993716b3064f549a9f8d3a97277e (patch)
tree8a14253895f67924b68dc146a10689d1d62f1b52 /gnu/packages/python-science.scm
parent4e5001f915e491e07bfce1c3bfecea0223495e4d (diff)
gnu: Add python-pylems.
* gnu/packages/python-science.scm (python-pylems): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 58d127277c..6061b432a7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1687,6 +1687,26 @@ Out-of-Core DataFrames (similar to Pandas), to visualize and explore big
tabular datasets. This package provides the core modules of Vaex.")
(license license:expat)))
+(define-public python-pylems
+ (package
+ (name "python-pylems")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyLEMS" version))
+ (sha256
+ (base32
+ "074azbyivjbwi61fs5p8z9n6d8nk8xw6fmln1www13z1dccb3740"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lxml))
+ (home-page "https://github.com/LEMS/pylems")
+ (synopsis
+ "Python support for the Low Entropy Model Specification language (LEMS)")
+ (description
+ "A LEMS simulator written in Python which can be used to run
+NeuroML2 models.")
+ (license license:lgpl3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar