summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSkylar Chan <schan12@umd.edu>2024-02-02 18:35:58 -0500
committerChristopher Baines <mail@cbaines.net>2024-02-10 10:37:58 +0000
commite02265a2f9c7e2e0201590bef5fad95f00798514 (patch)
treeefd66b402415cc939706131bef568e2a47d77a98 /gnu/packages/python-web.scm
parent6621e5bbab765af86fa8ee795c7d41db5d75707a (diff)
gnu: whoogle-search: Update to 0.8.4.
* gnu/packages/python-web.scm (whoogle-search): Update to 0.8.4. [propagated-inputs]: Add python-validators. Change-Id: I4543808d662e7e946c8a398b28ca963e75d4bfd1 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c0cc46e5f..2dd5dd1c5a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5342,13 +5342,13 @@ with oauthlib.")
(define-public whoogle-search
(package
(name "whoogle-search")
- (version "0.8.3")
+ (version "0.8.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "whoogle-search" version))
(sha256
(base32
- "09b9k97jflajvrs0npyz994rj8xkk400s98jw63b6vpsgw9q9nk4"))))
+ "0hsy4l98nzj6i1lf63wvqd0yharkaz44zsxh863ymy47rxnwimz7"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -5364,6 +5364,7 @@ with oauthlib.")
python-dotenv
python-requests
python-stem
+ python-validators
python-waitress))
(home-page "https://github.com/benbusby/whoogle-search")
(synopsis "Self-hosted, ad-free, privacy-respecting metasearch engine")