summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 09:55:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:17 -0400
commit718b4687c93b5ea5c92238807cf0fbd2bf49d70d (patch)
tree2485177fba6475189f191d3fc93ba9a416a2363f /gnu/packages/python-web.scm
parente27acc6fc710014505766566d1676d10030d8fee (diff)
gnu: python-aiosignal: Update to 1.3.1.
* gnu/packages/python-web.scm (python-aiosignal): Update to 1.3.1. [build-system]: Use pyproject-build-system. [arguments]: Remove #:phases. Add #:test-flags. [native-inputs]: Add python-pytest-cov.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fca04e91c4..8afdf1a98c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -290,23 +290,17 @@ by calling @code{FrozenList.freeze}.")
(define-public python-aiosignal
(package
(name "python-aiosignal")
- (version "1.2.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiosignal" version))
(sha256
- (base32 "1wkxbdgw07ay8yzx3pg1jcm46p3d21rfb5g4k17ysz3vdkdngvbq"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "tests")))))))
+ (base32 "1z4cnqww6j0xl6f3vx2r6kfv1hdny1pnlll7difvfj8nbvhrdkal"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:test-flags #~(list "tests")))
(propagated-inputs (list python-frozenlist))
- (native-inputs (list python-pytest python-pytest-asyncio))
+ (native-inputs (list python-pytest python-pytest-asyncio python-pytest-cov))
(home-page "https://github.com/aio-libs/aiosignal")
(synopsis "Callback manager for Python @code{asyncio} projects")
(description "This Python module provides @code{Signal}, an abstraction to