summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 13:26:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:54 +0100
commit71dc990f2271dadb8aaa22b87885491466835697 (patch)
tree3f4ff2af57190258df369b759185ad6f936ec806 /gnu/packages/python-web.scm
parent461dff26518c05c22e946cc1afc89b094159a5d1 (diff)
gnu: python-flask-restful: Update to 0.3.9.
* gnu/packages/python-web.scm (python-flask-restful): Update to 0.3.9. [source]: Remove patch. [build-system]: Use pyproject-build-system. [arguments]: Disable "test_redirect" test; remove 'fix-imports phase. [native-inputs]: Replace python-nose with python-pytest. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/python-flask-restful-werkzeug-compat.patch: Remove file.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7543e05f47..18c0b47b67 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3924,35 +3924,28 @@ apps.")
(define-public python-flask-restful
(package
(name "python-flask-restful")
- (version "0.3.8")
+ (version "0.3.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-RESTful" version))
- (patches (search-patches "python-flask-restful-werkzeug-compat.patch"))
(sha256
(base32
- "05b9lzx5yc3wgml2bcq50lq35h66m8zpj6dc9advcb5z3acsbaay"))))
- (build-system python-build-system)
+ "0gm5dz088v3d2k1dkcp9b3nnqpkk0fp2jly870hijj2xhc5nbv6c"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-imports
- (lambda _
- (substitute* "flask_restful/__init__.py"
- (("flask\\.helpers") "flask.scaffold")))))))
+ ;; This test fails because '/' is not 'http://localhost/'.
+ (list #:test-flags '(list "-k" "not test_redirect")))
(propagated-inputs
- (list python-aniso8601 python-flask python-pytz))
+ (list python-aniso8601 python-flask python-pytz))
(native-inputs
- (list ;; Optional dependency of Flask. Tests need it.
- python-blinker python-mock ; For tests
- python-nose)) ;for tests
- (home-page
- "https://www.github.com/flask-restful/flask-restful/")
- (synopsis
- "Flask module for creating REST APIs")
+ (list python-blinker
+ python-mock
+ python-pytest))
+ (home-page "https://www.github.com/flask-restful/flask-restful/")
+ (synopsis "Flask module for creating REST APIs")
(description
- "This package contains a Flask module for creating REST APIs.")
+ "This package contains a Flask module for creating REST APIs.")
(license license:bsd-3)))
(define-public python-flask-basicauth