summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:45:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:45:23 +0300
commit79c36951e49c775239dd6846ad66924179c1236b (patch)
treee45d7e6ac307398a7cee191f3e7d3611758b908c /gnu/packages/python-web.scm
parent54b040a31c12f85a04bb514b271a13db2fd5c6d7 (diff)
gnu: Add python-btrees.
* gnu/packages/python-web.scm (python-btrees): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 57254df587..e47912578d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4178,3 +4178,31 @@ Swagger.")
Python. It forms the core protocol for making objects interact
\"transparently\" with a database such as the ZODB.")
(license license:zpl2.1)))
+
+(define-public python-btrees
+ (package
+ (name "python-btrees")
+ (version "4.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "BTrees" version))
+ (sha256
+ (base32
+ "0iiq0g9k1g6qgqq84q9h6639vlvzznk1rgdm0rfcnnqkbkmsbr3w"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-persistent" ,python-persistent)
+ ("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-persistent" ,python-persistent)
+ ("python-transaction" ,python-transaction)
+ ("python-zope-testrunner" ,python-zope-testrunner)))
+ (home-page "https://github.com/zopefoundation/BTrees")
+ (synopsis "Scalable persistent object containers")
+ (description
+ "This package contains a set of persistent object containers built around a
+modified BTree data structure. The trees are optimized for use inside ZODB's
+\"optimistic concurrency\" paradigm, and include explicit resolution of
+conflicts detected by that mechanism.")
+ (license license:zpl2.1)))