summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-13 19:04:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-15 21:47:27 +0000
commit19db1551dc6f6180d2cda9084c2dec37bf4923c9 (patch)
tree2edae9fa003387c99e792c6a73991aab985de311 /gnu/packages/python-web.scm
parentda3764b75c741132c969d2f9b7812bbcf734a3e2 (diff)
gnu: python-requests-kerberos: Enable tests.
* gnu/packages/python-web.scm (python-requests-kerberos): Enable tests. [source]: Replace the PyPI release by the Github release. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest and python-pytest-mock. Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iea750cf722293c4054a6c6e43787806f8f2fd5e2
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d54a90f848..418100c084 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3300,16 +3300,21 @@ than Python’s urllib2 library.")
(package
(name "python-requests-kerberos")
(version "0.14.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests-kerberos" version))
- (sha256
- (base32
- "1lbgjs779cjxhz07lfl9dbyp3qfh8a3ir2393042wfg518jd3afd"))))
- (build-system python-build-system)
+ ;; No tests in the PyPI tarball.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/requests/requests-kerberos")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s30pcnlir3j2jmf7yh065f294cf3x0x5i3ldskn8mm0a3657mv3"))))
+ (build-system pyproject-build-system)
(propagated-inputs (list python-cryptography
python-pyspnego
python-requests))
+ (native-inputs (list python-pytest python-pytest-mock))
(home-page "https://github.com/requests/requests-kerberos")
(synopsis "Kerberos authentication handler for python-requests")
(description "This package provides a Kerberos authentication handler for