summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-28 22:39:12 +0100
committerMarius Bakke <marius@gnu.org>2020-11-28 22:39:12 +0100
commit4dadb4977908028bb0651d43ed4813cc988db92d (patch)
tree4647ae542d36e146fa91f728084b603dbfda6fa3 /gnu/packages/python-web.scm
parentfe5c9051cc25bd81aa6c88f5de06f10ff9532441 (diff)
parente827f40479dc6b652fbb92fe8a64b50cec83731b (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c1de44facd..f97e6a12e3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2428,13 +2428,13 @@ APIs.")
(define-public python-requests
(package
(name "python-requests")
- (version "2.23.0")
+ (version "2.24.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests" version))
(sha256
(base32
- "1rhpg0jb08v0gd7f19jjiwlcdnxpmqi1fhvw7r4s9avddi4kvx5k"))))
+ "06r3017hz0hzxv42gpg73l8xvdjbzw7q904ljvp36b5p3l9rlmdk"))))
(build-system python-build-system)
(propagated-inputs
`(("python-certifi" ,python-certifi)
@@ -2681,7 +2681,6 @@ authenticated session objects providing things like keep-alive.")
("python-certifi" ,python-certifi)
("python-cryptography" ,python-cryptography)
("python-idna" ,python-idna)
- ("python-ipaddress" ,python-ipaddress)
("python-pyopenssl" ,python-pyopenssl)
("python-pysocks" ,python-pysocks)))
(home-page "https://urllib3.readthedocs.io/")
@@ -2690,6 +2689,7 @@ authenticated session objects providing things like keep-alive.")
"Urllib3 supports features left out of urllib and urllib2 libraries. It
can reuse the same socket connection for multiple requests, it can POST files,
supports url redirection and retries, and also gzip and deflate decoding.")
+ (properties `((python2-variant . ,(delay python2-urllib3))))
(license license:expat)))
;; Some software requires an older version of urllib3, notably Docker.
@@ -2705,7 +2705,12 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(define-public python2-urllib3
- (package-with-python2 python-urllib3))
+ (let ((base (package-with-python2 (strip-python2-variant python-urllib3))))
+ (package/inherit
+ base
+ (propagated-inputs
+ `(("python-ipaddress" ,python2-ipaddress)
+ ,@(package-propagated-inputs base))))))
(define-public awscli
(package