summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 10:20:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 10:20:32 -0400
commit3d297a0017210f1dd135592efb10846840a8af88 (patch)
tree8868c35a558a6288b5097d65bee42dda291178e4 /gnu/packages/python-web.scm
parent279349209e44aaae6ca2aba328fe2a4d2da99f12 (diff)
parent6737d8d3248301e65bc24291b1a776e4aa8c3648 (diff)
Merge branch 'master' into staging
With resolved conflicts in: gnu/local.mk gnu/packages/freedesktop.scm gnu/packages/gnuzilla.scm
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6ae6673ad3..255c5d67ec 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4984,12 +4984,17 @@ hard or impossible to fix in cssselect.")
;; The tests are prone to get stuck. Use pytest-timeout’s --timeout
;; flag to get a meaningful idea about where.
(invoke "pytest" "-vv" "--timeout=300"
- "-k" ,(string-append
+ "--timeout-method=thread"
+ "-k" (string-append
;; Timeout, because SIGINT cannot be sent to child.
"not test_signals_sigint_pycode_continue "
"and not test_signals_sigint_pycode_stop "
"and not test_signals_sigint_uvcode "
"and not test_signals_sigint_uvcode_two_loop_runs "
+ ;; This test is racy and prone to get stuck on
+ ;; various platforms, possibly a aiohttp issue:
+ ;; https://github.com/MagicStack/uvloop/issues/412
+ "and not test_remote_shutdown_receives_trailing_data "
;; It looks like pytest is preventing
;; custom stdout/stderr redirection,
;; even with -s.