summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-01 14:15:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-01 14:17:28 -0400
commitd0917d778284ee7d70bc80b0538e3b4ae67870f4 (patch)
treed658a4fb64b0ed051ef79e66f25b8449bc588510 /gnu/packages/python-web.scm
parent088962f3c29d958809f47fec81bb01aaf4592b8c (diff)
gnu: Add python-zope-sqlalchemy.
* gnu/packages/python-web.scm (python-zope-sqlalchemy): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 00ce3c63ff..905ed6a327 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2427,6 +2427,30 @@ internationalized messages within program source text.")
defining data schemas.")
(license license:zpl2.1)))
+(define-public python-zope-sqlalchemy
+ (package
+ (name "python-zope-sqlalchemy")
+ (version "1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.sqlalchemy" version))
+ (sha256
+ (base32
+ "1azm2awl2ra10xl6wps3yvy14jk2rpzvsyfsb9cncm97aydbwlww"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-sqlalchemy
+ python-transaction
+ python-zope-interface))
+ (native-inputs (list python-zope-testing))
+ (home-page "https://github.com/zopefoundation/zope.sqlalchemy")
+ (synopsis "Minimal SQLAlchemy transaction integration for Zope")
+ (description "The aim of this package is to unify the plethora of existing
+packages integrating SQLAlchemy with Zope's transaction management. As such,
+it only provides a data manager and makes no attempt to define a @i{zopeish}
+way to configure engines.")
+ (license license:zpl2.1)))
+
(define-public python-zope-configuration
(package
(name "python-zope-configuration")