summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-11-04 22:52:09 -0500
committerEfraim Flashner <efraim@flashner.co.il>2022-11-15 12:30:49 +0200
commitd15373655bb35c43465472c8ac987276a72765d5 (patch)
treed1e571b22cfd42ee8afc4681cf2a84cb040ce484 /gnu/packages/python-web.scm
parent3775e997baeda2791694df2333b1ab9a804da204 (diff)
gnu: python-bottle: Update to 0.12.23.
* gnu/packages/python-web.scm (python-bottle): Update to 0.12.23. [native-inputs]: Add python-pytest. [arguments]: Use pytest to call test suite. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d88b3a941d..f6b4faf692 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -45,7 +45,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -4451,14 +4451,23 @@ addon modules.")
(define-public python-bottle
(package
(name "python-bottle")
- (version "0.12.21")
+ (version "0.12.23")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bottle" version))
(sha256
- (base32 "0zl8sy4dhafyxqpavy7pjz0qzpakmhgh2qr6pwlw5f82rjv62z3q"))))
+ (base32 "0rs1w293gp5bhxip2cci8mfkhld6n5qcznvlna3nxclz76mf6gb8"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ (invoke "pytest" "-vvv"))))))))
+ (native-inputs (list python-pytest))
(home-page "https://bottlepy.org/")
(synopsis "WSGI framework for small web-applications")
(description "@code{python-bottle} is a WSGI framework for small web-applications.")