summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-21 00:34:48 +0100
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:32 +0100
commit160c6af5ce661bc6dcb7bf849cf8b7d95b18a594 (patch)
treec48fa63f63cf60be7f877855f0b64439403ae534 /gnu/packages/python-web.scm
parentf1163b8803a1530125b845f6a8a3269e1a29a152 (diff)
gnu: Add python-flask-cors.
* gnu/packages/python-web.scm (python-flask-cors): New public variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0e398a525f..e7518b66a5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -953,6 +953,30 @@ both of which are installed automatically if you install this library.")
(define-public python2-flask-babel
(package-with-python2 python-flask-babel))
+(define-public python-flask-cors
+ (package
+ (name "python-flask-cors")
+ (version "3.0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Cors" version))
+ (sha256
+ (base32
+ "1f36hkaxc92zn12f88fkzwifdvlvsnmlp1dv3p5inpcc500c3kvb"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-nose" ,python-nose)
+ ("python-packaging" ,python-packaging)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://flask-cors.readthedocs.io/en/latest/")
+ (synopsis "Handle Cross-Origin Resource Sharing with Flask")
+ (description
+ "This package provides a Flask extension for handling @acronym{CORS,Cross
+Origin Resource Sharing}, making cross-origin AJAX possible.")
+ (license license:expat)))
+
(define-public python-html5lib
(package
(name "python-html5lib")