summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-16 17:07:26 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-17 07:54:17 +0300
commit6a1f35937a450c22b28bee7432139617437720f9 (patch)
tree72432cf769bef48240a80085441064254809d528 /gnu/packages/python-web.scm
parente87b063f4c36ee07c70aa8e9cda60f609675804e (diff)
gnu: Add python-hypercorn.
* gnu/packages/python-web.scm (python-hypercorn): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c68609fa5d..1b97d1401d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1059,6 +1059,48 @@ choose to use, ensuring that you can communicate via WebSockets, as defined in
RFC6455, regardless of your programming paradigm.")
(license license:expat)))
+(define-public python-hypercorn
+ (package
+ (name "python-hypercorn")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Hypercorn" version))
+ (sha256
+ (base32 "15dgy47a18w2ls3hwykra1cyf7yzxmfjqnsqml482p12cxr2xwqr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (propagated-inputs
+ `(("python-h11" ,python-h11)
+ ("python-h2" ,python-h2)
+ ("python-priority" ,python-priority)
+ ("python-toml" ,python-toml)
+ ("python-typing-extensions" ,python-typing-extensions)
+ ("python-wsproto" ,python-wsproto)))
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-trio" ,python-pytest-trio)
+ ("python-trio" ,python-trio)))
+ (home-page "https://gitlab.com/pgjones/hypercorn/")
+ (synopsis "ASGI Server based on Hyper libraries")
+ (description
+ "Hypercorn is an ASGI web server based on the sans-io hyper, h11, h2, and
+wsproto libraries and inspired by Gunicorn. It supports HTTP/1, HTTP/2,
+WebSockets (over HTTP/1 and HTTP/2), ASGI/2, and ASGI/3 specifications. It can
+utilise asyncio, uvloop, or trio worker types.")
+ (license license:expat)))
+
(define-public python-tornado
(package
(name "python-tornado")