summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-10-29 10:47:54 +0100
committerLudovic Courtès <ludo@gnu.org>2020-10-31 23:16:44 +0100
commit70876b0793765b882f3fae3d8465b68b38e1eeb8 (patch)
treee7393b9fa573be24a5cf46b102d28ef25228b7ba /gnu/packages/python-web.scm
parent1e0c382605f79ccf60376918180805c742586394 (diff)
gnu: httpie: Update to 2.3.0.
* gnu/packages/python-web.scm (httpie): Update to 2.3.0. [propagated-inputs]: Add python-requests-toolbelt. [home-page]: Update URL. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1b6f0290ab..cf71a64e7c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -429,14 +429,14 @@ other HTTP libraries.")
(define-public httpie
(package
(name "httpie")
- (version "2.2.0")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "18058k0i3cc4ixvgzj882w693lf40283flvspbrvd876iq42ib1i"))))
+ "15ngl3yc186gkgqdx8iav9bpj8gxjpzz26y32z92jwyhj4cmfh6m"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
@@ -444,8 +444,9 @@ other HTTP libraries.")
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-pygments" ,python-pygments)
- ("python-requests" ,python-requests)))
- (home-page "https://httpie.org/")
+ ("python-requests" ,python-requests)
+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1)))
+ (home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description
"A command line HTTP client with an intuitive UI, JSON support,