summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 12:56:56 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:54 +0200
commite2ac59f984d68f6d1011633df6d612d2bb54229f (patch)
tree266c0544fbf46168dcede1110eeac20a4641c74d /gnu/packages/python-web.scm
parent384aa00c7deead8e7db492ed0f7949a18f8ccffb (diff)
gnu: python-webassets: Update to 2.0.
* gnu/packages/python-web.scm (python-webassets): Update to 2.0. [arguments]: New field.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7fd653b7a5..c0d0d5662b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3173,15 +3173,29 @@ for Flask.")
(define-public python-webassets
(package
(name "python-webassets")
- (version "0.12.1")
+ (version "2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "webassets" version))
(sha256
(base32
- "1nrqkpb7z46h2b77xafxihqv3322cwqv6293ngaky4j3ff4cing7"))))
+ "1kc1042jydgk54xpgcp0r1ib4gys91nhy285jzfcxj3pfqrk4w8n"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-some-tests
+ (lambda _
+ ;; This test requires 'postcss' and 'babel' which are
+ ;; not yet available in Guix.
+ (delete-file "tests/test_filters.py")
+ #t))
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv"))))))
(native-inputs
`(("python-jinja2" ,python-jinja2)
("python-mock" ,python-mock)