summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-16 17:04:54 -0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-17 07:45:16 +0300
commitfc9be8db2dacc73f46cf380e2b9a9c492386036f (patch)
treed8c070aca3aed59805d234b25f3bb4d657b2c60f /gnu/packages/python-web.scm
parentaee0f559f29d957367e9420d7797e646a9127d23 (diff)
gnu: Add python-h11.
* gnu/packages/python-web.scm (python-h11): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f9c8157f0d..957c5ceeff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -527,6 +527,34 @@ into HTTP/2 frames.")
for use in Python programs that implement HTTP/2.")
(license license:expat)))
+(define-public python-h11
+ (package
+ (name "python-h11")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "h11" version))
+ (sha256
+ (base32 "1qfad70h59hya21vrzz8dqyyaiqhac0anl2dx3s3k80gpskvrm1k"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/python-hyper/h11")
+ (synopsis "Pure-Python, bring-your-own-I/O implementation of HTTP/1.1")
+ (description
+ "This is a little HTTP/1.1 library written from scratch in Python, heavily
+inspired by hyper-h2. It's a bring-your-own-I/O library; h11 contains no IO
+code whatsoever. This means you can hook h11 up to your favorite network API,
+and that could be anything you want.")
+ (license license:expat)))
+
(define-public python-h2
(package
(name "python-h2")