summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-13 00:06:00 +0200
committerMarius Bakke <marius@gnu.org>2021-10-13 00:22:07 +0200
commit115352b5454d23663e2d1a1815bdd28513fb3dbf (patch)
tree3e09044dd09f2f6a7551dc9e88efa72fe3af2c2c /gnu/packages/python-web.scm
parent6c1724f6cd5636605e0aa1acbf6aadde41bd5004 (diff)
gnu: python-zope-component: Respect '--without-tests'.
* gnu/packages/python-web.scm (python-zope-component)[arguments]: Honor TESTS? in the check phase.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e058b4ca50..27133e4605 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2293,9 +2293,10 @@ security policies on Python objects.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "setup.py" "test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python" "setup.py" "test")
+ (format #t "test suite not run~%")))))))
(native-inputs
`(("python-persistent" ,python-persistent)
("python-zope-configuration" ,python-zope-configuration-bootstrap)