summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-08-06 11:17:19 -0300
committerVinicius Monego <monego@posteo.net>2023-09-02 11:17:02 -0300
commit2d8b35635253636f4ef3d454761ca03e85b0535f (patch)
tree48c6aafa108a36a04465960fa1ec4b76c96419b8 /gnu/packages/python-web.scm
parent7c951ce67d3da496fc5752e435c54a108a30597b (diff)
gnu: python-w3lib: Update to 2.1.2.
* gnu/packages/python-web.scm (python-w3lib): Update to 2.1.2. [source]: Remove patch. [build-system]: Use pyproject-build-system. [arguments]: Do not override the check phase. [native-inputs]: Remove python-six. * gnu/packages/patches/python-w3lib-fix-test-failure.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4c38636af5..5d221a1038 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7752,25 +7752,17 @@ GCS, Azure Blob Storage, gzip, bz2, etc.)")
(define-public python-w3lib
(package
(name "python-w3lib")
- (version "1.22.0")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "w3lib" version))
- (patches (search-patches "python-w3lib-fix-test-failure.patch"))
(sha256
(base32
- "1pv02lvvmgz2qb61vz1jkjc04fgm4hpfvaj5zm4i3mjp64hd1mha"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ "1cd4b3w5g3pfccsg79kjj27fwi216ip927rjq7isp8pfjzlp8nzd"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-six))
+ (list python-pytest))
(home-page "https://github.com/scrapy/w3lib")
(synopsis "Python library of web-related functions")
(description