summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-01 10:52:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-01 10:52:36 +0300
commit676f6085468ab1fb1be8ce24d073f24032a02b75 (patch)
treea22a4f8dfa6f66d232501b68426256a5846f83c3 /gnu/packages/python-web.scm
parent8b3ae46ae3f80e285fe9c680bdaaaad1c57406b9 (diff)
gnu: python-urllib3: Adjust dependencies per architecture.
* gnu/packages/python-web.scm (python-urllib3)[propagated-inputs]: Only include python-cryptography, python-pyopenssl on architectures where they are supported.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d7ad051007..9dfc18867f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3404,12 +3404,19 @@ addon for removing tracking fields from URLs.")
(build-system python-build-system)
(arguments `(#:tests? #f))
(propagated-inputs
- (list ;; These 5 inputs are used to build urrlib3[secure]
- python-certifi
- python-cryptography
- python-idna
- python-pyopenssl
- python-pysocks))
+ (append
+ ;; These 5 inputs are used to build urrlib3[secure]
+ (list python-certifi)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-cryptography))
+ (list python-cryptography)
+ '())
+ (list python-idna)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-pyopenssl))
+ (list python-pyopenssl)
+ '())
+ (list python-pysocks)))
(home-page "https://urllib3.readthedocs.io/")
(synopsis "HTTP library with thread-safe connection pooling")
(description