summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-20 11:21:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-20 18:27:44 +0200
commite0deaf0a85a1a6a0f8e6d619d25495eb1b621c2a (patch)
tree9e72e73f3fcc4a1f6836bb4199f2096a4e43fbc7 /gnu/packages/python-web.scm
parenta39aac3352bf81f9ed7d4bc25dab650be8bdfedb (diff)
gnu: Add python-google-auth-1.
* gnu/packages/python-web.scm (python-google-auth-1): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 93e0c830a9..ca41684542 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7253,6 +7253,42 @@ of the CRC32C hashing algorithm.")
server-to-server authentication mechanisms to access Google APIs.")
(license license:asl2.0)))
+(define-public python-google-auth-1
+ (package
+ (inherit python-google-auth)
+ (name "python-google-auth")
+ (version "1.35.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-auth" version))
+ (sha256
+ (base32 "13nqj6hikvbdmbs1vb78c88ym0pd03m09ch00biqw64c0blkn0xp"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs
+ (list python-cachetools
+ python-pyasn1-modules
+ python-rsa
+ python-six
+ ;; For the extras
+ python-pyopenssl
+ python-pyu2f))
+ (native-inputs
+ (list python-flask
+ python-freezegun
+ python-oauth2client
+ python-pytest
+ python-pytest-localserver
+ python-requests
+ python-responses
+ python-urllib3))))
+
(define-public python-google-resumable-media
(package
(name "python-google-resumable-media")