summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-11 16:07:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:48 +0200
commit063868688355c08bd568a78bc3b4d1a44f5f8f06 (patch)
tree80b62858079590b3ae8b94bea21b78778834f008 /gnu/packages/python-xyz.scm
parentbbd0fc89351034ad88530cb07fb7eb8631d2d313 (diff)
gnu: python-annotated-types: Update package.
* gnu/packages/python-xyz.scm (python-annotated-types) [propagated-inputs]: Add python-typing-extensions. [description]: Expand. Change-Id: I90d198602a9f3f42be26f5728a61b3089b32a81e
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9369cc06a8..a012241dbd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6244,9 +6244,14 @@ important tasks for becoming a daemon process:
(native-inputs
(list python-hatchling
python-pytest))
+ (propagated-inputs (list python-typing-extensions))
(home-page "https://github.com/annotated-types/annotated-types")
(synopsis "Reusable constraint types to use with typing.Annotated")
- (description "Reusable constraint types to use with typing.Annotated")
+ (description "This package provides metadata objects which can be used to
+represent common constraints such as upper and lower bounds on scalar values and
+collection sizes, a Predicate marker for runtime checks, and descriptions of how
+we intend these metadata to be interpreted. In some cases, we also note
+alternative representations which do not require this package.")
(license license:expat)))
(define-public python-anytree