summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-10 22:03:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:13 +0100
commit08b9e29d4672d2209026f4b7fa592abb958cbd34 (patch)
tree7bd4dea7f7de9e412ab6b8cceca00cc2dff3285c /gnu/packages/python-xyz.scm
parentb72df3bbb3625261d6b344c232da3c0589a0f3b7 (diff)
gnu: python-bokeh: Skip failing PIL test.
The test compares base64-encoded gifs; the gifs look identical but the base64-encoded data differs. Since the result seems fine, disabling this PIL test is probably okay. * gnu/packages/python-xyz.scm (python-bokeh)[arguments]: Ignore failing test_transform_PIL test.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5c4e3e9f7..2acba1fa39 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15466,7 +15466,10 @@ enhancements to optimization and data fitting problems.")
(delete-file "tests/unit/bokeh/models/test_sources.py")
(delete-file "tests/unit/bokeh/embed/test_bundle.py")
- (invoke "pytest" "-v")))))))
+ ;; XXX: This one test transforms a gif of a red box. It
+ ;; transforms it all right but the base64 doesn't look as
+ ;; expected, probably because of a change in pillow.
+ (invoke "pytest" "-v" "-k" "not test_transform_PIL")))))))
(propagated-inputs
(list node-lts
python-jinja2