summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:13:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:13:24 +0000
commit1a2c374c2cca5694ec2a38f01e33b9bce7218d44 (patch)
tree88bc27b336c5ea1c22621fd810a95a6f2edd6a93 /gnu/packages/python-xyz.scm
parente355848578d15fb8f76bc6cbe5c15d9a9b400acf (diff)
gnu: python-xyzservices: Simplify package.
* gnu/packages/python-xyz.scm (python-xyzservices) [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Skip tests requiring request module, as seen in project's GitHub Actions. <#:phases>: Use standard 'check phase. Change-Id: I9092e282bebc8539e9ceed5ec87559d64513a486
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c83442c906..d93bbfe6ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28276,14 +28276,10 @@ translating between quadkey and tile coordinates.")
(uri (pypi-uri "xyzservices" version))
(sha256
(base32 "1paxv4i0dws85md7csv7pf80jl3xh792mx8rxnsrk61ks3ivbsyg"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (list
+ #:test-flags #~(list "-m" "not request")))
(native-inputs
(list python-pytest python-mercantile python-requests))
(home-page "https://github.com/geopandas/xyzservices")