summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-03 16:35:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 16:35:48 +0200
commit1b956b17b234d20fa7cd138cb099143f688e469c (patch)
treec07eca88a7d7454bd72c62d83beecc2dad3fae74 /gnu/packages/python-xyz.scm
parentd56a6fa9b2ed46e3a2555d962f5ef84284c85f9b (diff)
gnu: python-xopen: Update to 1.7.0.
* gnu/packages/python-xyz.scm (python-xopen): Update to 1.7.0. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add pigz, python-isal, and python-typing-extensions; move python-setuptools-scm from here... [native-inputs]: ...to here; add python-pytest and python-pytest-timeout. [description]: Reflow.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7348f79dfd..1085f32d38 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20729,24 +20729,26 @@ from the header, as well as section details and data available.")
(define-public python-xopen
(package
(name "python-xopen")
- (version "0.8.2")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xopen" version))
(sha256
(base32
- "1xrlcnd6fri3w97zzzp6vyk4l21yq1lc8r4wksi06hgpkbh4jdq0"))))
- (build-system python-build-system)
+ "17qda88irg77qdm2kkxq4zgdhwfgykcpdgd4cx3xfpp9k219q7wh"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-setuptools-scm))
+ (list pigz python-isal python-typing-extensions))
+ (native-inputs
+ (list python-pytest python-pytest-timeout python-setuptools-scm))
(home-page "https://github.com/marcelm/xopen/")
(synopsis "Open compressed files transparently")
- (description "This module provides an @code{xopen} function that works like
- Python's built-in @code{open} function, but can also deal with compressed files.
- Supported compression formats are gzip, bzip2 and, xz, and are automatically
- recognized by their file extensions. The focus is on being as efficient as
- possible on all supported Python versions.")
+ (description "This module provides an @code{xopen} function that works
+like Python's built-in @code{open} function, but can also deal with compressed
+files. Supported compression formats are gzip, bzip2 and, xz, and are
+automatically recognized by their file extensions. The focus is on being as
+efficient as possible on all supported Python versions.")
(license license:expat)))
(define-public python-cheetah