summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-13 21:15:49 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-17 11:17:59 +0100
commit1e0b80b9e15d1d89eb2e10b7e62afaed4bbd77f8 (patch)
tree5bd786d8e407a3cb21afe7d2ea7800ab2a2de781 /gnu/packages/python-xyz.scm
parent4acaa72e7b7d448dd24b1776331fb245053af51e (diff)
gnu: Add python-concurrent-log-handler.
* gnu/packages/python-xyz.scm (python-concurrent-log-handler): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4c7c82204e..e0d74bb4e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -400,6 +400,35 @@ Jupytext are:
")
(license license:expat)))
+(define-public python-concurrent-log-handler
+ (package
+ (name "python-concurrent-log-handler")
+ (version "0.9.25")
+ ;; No tests in the PyPI tarball.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Preston-Landers/concurrent-log-handler")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jp4zkm0idfdsrq3jzb52iqfkh6xzm7sacz1sa34ffnkyqdk3xzh"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-portalocker))
+ (native-inputs (list python-hatchling python-pytest))
+ (home-page "https://github.com/Preston-Landers/concurrent-log-handler")
+ (synopsis
+ "Additional log handler for Python's standard @code{logging} package")
+ (description
+ "This package provides an additional log handler for Python's standard
+@code{logging} package (PEP 282). This handler will write log events to a log
+file which is rotated when the log file reaches a certain size. Multiple
+processes can safely write to the same log file concurrently and rotated logs
+can be gzipped if desired. An optional threaded queue logging handler is
+provided to perform logging in the background.")
+ (license license:asl2.0)))
+
(define-public python-logzero
(package
(name "python-logzero")