summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 23:22:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 23:22:01 +0200
commit351d193eb13b59c03f4e9eaca095c981149019db (patch)
tree0d25d80a19a74abdb10e2567744cdd157e52e8a1 /gnu/packages/python-xyz.scm
parent27341afe53bf073e2fbda042d81a29757a8d9bfd (diff)
gnu: python-orjson: Reuse phases from pyproject-build-system.
* gnu/packages/python-xyz.scm (python-orjson)[arguments]: Include modules from pyproject-build-system; use their 'build and 'install phases instead of duplicating their contents.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e57f7abd0..76e8c7480d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2827,9 +2827,14 @@ help formatter.")
(build-system cargo-build-system)
(arguments
(list
+ #:imported-modules `(,@%cargo-build-system-modules
+ ,@%pyproject-build-system-modules)
+ #:modules '((guix build cargo-build-system)
+ ((guix build pyproject-build-system) #:prefix py:)
+ (guix build utils))
#:phases
#~(modify-phases %standard-phases
- (add-after 'install 'build-python-module
+ (add-after 'install 'prepare-python-module
(lambda _
;; We don't use maturin.
(delete-file "pyproject.toml")
@@ -2857,15 +2862,11 @@ exclude =
integration
test
Cargo.toml
-" #$version)))
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+" #$version)))))
+ (add-after 'prepare-python-module 'build-python-module
+ (assoc-ref py:%standard-phases 'build))
(add-after 'build-python-module 'install-python-module
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
+ (assoc-ref py:%standard-phases 'install))
(add-after 'install-python-module 'install-python-library
(lambda _
(let ((site (string-append #$output "/lib/python"