summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-04-29 01:31:09 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-19 16:46:35 +0200
commit6e80fa2f3cb86f662f03dfd613c9d943bb9c913f (patch)
treefa8faab42b6f1946bcbd94c5f6750674312b2070 /gnu/packages/python-xyz.scm
parent228e08c74ec0caece271966dac7057520ac72891 (diff)
gnu: Add python-jaraco-test.
* gnu/packages/python-xyz.scm (python-jaraco-test): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 547d18fa65..f7e3f6f538 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9698,6 +9698,37 @@ module with a few extra procedures.")
releases.")
(license license:expat)))
+(define-public python-jaraco-test
+ (package
+ (name "python-jaraco-test")
+ (version "5.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.test" version))
+ (sha256
+ (base32
+ "0h0x8qmvfkfqvwdx2m7kwhn53sg26k8gkaas7s1730ak772zqrvz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "-k" "http"))))))
+ (propagated-inputs (list python-jaraco-context python-jaraco-functools))
+ (native-inputs (list python-flake8
+ python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler
+ python-pytest-flake8
+ python-pytest-mypy))
+ (home-page "https://github.com/jaraco/jaraco.test")
+ (synopsis "Testing support by jaraco")
+ (description "This package provides testing support by jaraco.")
+ (license license:expat)))
+
(define-public python-simplegeneric
(package
(name "python-simplegeneric")