summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commit789f7e9a3d37135d22d0a84c987fe3877131fd06 (patch)
treee5ecd3aeafbbdabc7afb353dbf176eb3bc9af6ae /gnu/packages/python-xyz.scm
parenta879385de12e9bbfe90b39e14733ab261e88c171 (diff)
gnu: fuse@3: Bind to default FUSE variable.
* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db3e69fb45..a59879cdf6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13306,7 +13306,7 @@ third-party code.")
"1jaf790rsxvz3hs9fbr3hrnmg0xzl6a2bqfa10bbbsjsdbcpk762"))))
(build-system python-build-system)
(inputs
- (list fuse attr))
+ (list fuse-2 attr))
(native-inputs
(list pkg-config python-pytest))
(synopsis "Python bindings for FUSE")
@@ -24387,10 +24387,9 @@ commit, but it also includes some other useful statistics.")
(let ((fuse (assoc-ref inputs "fuse")))
(substitute* "fuse.py"
(("find_library\\('fuse'\\)")
- (string-append "'" fuse "/lib/libfuse.so'")))
- #t))))))
+ (string-append "'" fuse "/lib/libfuse.so'")))))))))
(propagated-inputs
- (list fuse))
+ (list fuse-2))
(home-page "https://github.com/fusepy/fusepy")
(synopsis "Simple ctypes bindings for FUSE")
(description "Python module that provides a simple interface to FUSE and
@@ -24417,10 +24416,9 @@ MacFUSE. The binding is created using the standard @code{ctypes} library.")
(let ((fuse (assoc-ref inputs "fuse")))
(substitute* "fusepyng.py"
(("os.environ.get\\('FUSE_LIBRARY_PATH'\\)")
- (string-append "\"" fuse "/lib/libfuse.so\""))))
- #t)))))
+ (string-append "\"" fuse "/lib/libfuse.so\"")))))))))
(inputs
- (list fuse))
+ (list fuse-2))
(propagated-inputs
(list python-paramiko))
(home-page "https://github.com/rianhunter/fusepyng")
@@ -31962,10 +31960,10 @@ Psycopg 2 is both Unicode and Python 3 friendly.")
(base32 "0cvybynv9igssfa4l13q09gb6m7afmwk34wsbq8jk14sqpd4dl92"))))
(build-system python-build-system)
(native-inputs (list pkg-config))
- (inputs (list fuse-3))
+ (inputs (list fuse))
(propagated-inputs (list python-pytest-trio))
(home-page "https://github.com/libfuse/pyfuse3")
- (synopsis "Python bindings FUSE 3")
+ (synopsis "Python bindings to FUSE 3")
(description "This package provides Python 3 bindings for libfuse 3 with
async I/O support.")
(license license:gpl2+)))