summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorAwesomeAdam54321 <adam.faiz@disroot.org>2023-03-09 21:59:48 +0800
committerjgart <jgart@dismail.de>2023-07-11 21:39:27 -0500
commitb073fb9896e4c6f26a02dca31a9e8f49a16d92fa (patch)
treeded9f1ab9167add58f79e4c7208a0def285d7d9f /gnu/packages/python-xyz.scm
parent64b720e65e8d3536d78ed8e742422f5872d4c1cf (diff)
gnu: Add python-redo.
* gnu/packages/python-xyz.scm (python-redo): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb5972dad7..6d460e286e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30468,6 +30468,41 @@ result.")
lets you write CommonMark inside of Docutils & Sphinx projects.")
(license license:expat)))
+(define-public python-redo
+ ;; The latest release isn't tagged:
+ ;; https://github.com/mozilla-releng/redo/issues/76
+ (let ((commit "50cfe8e3656f253f9e51df3a998530351d2d9a8c")
+ (revision "0"))
+ (package
+ (name "python-redo")
+ (version (git-version "2.0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch) ; There are no tests in the PyPI release.
+ (uri (git-reference
+ (url "https://github.com/mozilla-releng/redo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xpylx97qr4ikdhsr208ri41007mpp57a4n8mmlmlqmdljmsdpdb"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-mock
+ python-pytest))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The project uses tox to run the tests via pytest.
+ (invoke "pytest")))))))
+ (home-page "https://github.com/mozilla-releng/redo")
+ (synopsis "Utilities to retry Python callables")
+ (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+ (license license:mpl2.0))))
+
(define-public python-pyhull
(package
(name "python-pyhull")