summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-27 17:07:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-29 12:01:22 +0200
commitbe42a9f5eb411c752c95106a68631dfb4648e083 (patch)
treeb8a60280de5a22630262b2e00812ccbcd96cf024 /gnu/packages/python-xyz.scm
parentb68bf7d3da368b0a3d330942432892e846d9d74d (diff)
gnu: Add python-rasterio.
* gnu/packages/python-xyz.scm (python-rasterio): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6a9e07d49..f6f34c12b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1766,6 +1766,51 @@ It can handle tasks such as scanning, tracerouting, probing, unit tests,
attacks or network discovery.")
(license license:gpl2)))
+(define-public python-rasterio
+ (package
+ (name "python-rasterio")
+ (version "1.3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "rasterio" version))
+ (sha256
+ (base32
+ "012341c1rlcdr9rkg97lbhxrwzn4sr2xah4zjfnqy2r1227wpzdb"))))
+ (properties
+ '((updater-ignored-native-inputs . ("gdal" "python-cython"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #false ;test data not present
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (propagated-inputs (list python-affine
+ python-attrs
+ python-certifi
+ python-click
+ python-click-plugins
+ python-cligj
+ python-numpy
+ python-setuptools
+ python-snuggs))
+ (native-inputs (list gdal
+ python-boto3
+ python-cython
+ python-hypothesis
+ python-packaging
+ python-pytest
+ python-pytest-cov
+ python-shapely))
+ (home-page "https://github.com/rasterio/rasterio")
+ (synopsis "Fast and direct raster I/O for use with Numpy and SciPy")
+ (description "This package implements fast and direct raster I/O for use
+with Numpy and SciPy.")
+ (license license:bsd-3)))
+
(define-public python-shapely
(package
(name "python-shapely")