summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-07-03 17:57:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 17:57:53 +0200
commitcf7e0267adfc3cb83e477c2aebb61060c3c0cfd6 (patch)
tree0a48650a2d4d3e4a6915d3a6fed811bca6381db3 /gnu/packages/python-xyz.scm
parent07f083e94f4f5c5f53e4d8aa644de2064a6256c9 (diff)
gnu: Add python-cesium.
* gnu/packages/python-xyz.scm (python-cesium): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1085f32d38..8a9df4e6a9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -161,6 +161,7 @@
#:use-module (gnu packages adns)
#:use-module (gnu packages aidc)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages astronomy)
#:use-module (gnu packages attr)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
@@ -17308,6 +17309,45 @@ Eventlet, or gevent. Tasks can execute asynchronously (in the background) or
synchronously (wait until ready).")
(license license:bsd-3)))
+(define-public python-cesium
+ (package
+ (name "python-cesium")
+ (version "0.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cesium" version))
+ (sha256
+ (base32
+ "0jr0ycqz9ns6mcskm4sxx92k40fj3v0x9knjaw5ac9f3mpqxsfbv"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; The installed test files contain the /gnu/store location, not the
+ ;; location of the discovered test files from the build directory.
+ ;; The test framework doesn't like this. The easiest way around
+ ;; this mismatch is to jump to the output directory.
+ (add-before 'check 'check-chdir
+ (lambda _ (chdir #$output))))))
+ (propagated-inputs
+ (list python-click ;XXX required by python-dask
+ python-cloudpickle
+ python-dask
+ python-gatspy
+ python-joblib
+ python-numpy
+ python-pandas
+ python-scikit-learn
+ python-scipy
+ python-toolz))
+ (native-inputs (list python-cython python-pytest python-setuptools-scm))
+ (home-page "https://pypi.org/project/cesium/")
+ (synopsis "Library for time-series feature extraction and processing")
+ (description
+ "Cesium is a library for time-series feature extraction and processing.")
+ (license license:bsd-3)))
+
(define-public python-translitcodec
(package
(name "python-translitcodec")