summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-13 22:52:32 +0100
committerChristopher Baines <mail@cbaines.net>2024-07-11 10:24:46 +0100
commite44273ab5fd5028f2dac1f763b84db7bfb9f18a6 (patch)
tree791c48f089fbef4a462ac6466bdf648b19a23c55 /gnu/packages/python-xyz.scm
parentf915a39ab84ed2d201d3c762a776b4c9f47d6277 (diff)
gnu: python-natsort: Add en_US.UTF-8 locale for tests.
* gnu/packages/python-xyz.scm (python-natsort): Add en_US.UTF-8 locale for the package's tests. Change-Id: I5947b6550b9bc71d403685756ead4f1c77c99012
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7b05598d14..97c07c02ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22730,7 +22730,10 @@ implementation of your Python package and its public API surface.")
(when tests?
(invoke "pytest" "-v")))))))
(native-inputs
- (list python-hypothesis python-pytest-cov python-pytest-mock
+ (list glibc-utf8-locales ;; Tests want en_US.UTF-8
+ python-hypothesis
+ python-pytest-cov
+ python-pytest-mock
python-pytest))
(propagated-inputs ; TODO: Add python-fastnumbers.
(list python-pyicu))